Back
Resolved

Giftwhale is available

Started 20 Mar at 09:15am GMT.

Application API
Created

Giftwhale users may have experienced up to 1 hour's of downtime due to a planned database upgrade which took longer than expected to complete. All services are now functioning well, and due to the upgrade, load times should be reduced.

Posted 20 Mar at 09:15am GMT.