Back
Degraded

Fetch not working for some users
Started 25 Aug at 05:10pm BST, resolved 30 Aug at 09:00pm BST.
Product fetch service
Resolved
We have identified the cause of the issue and Fetch should now be working correctly for all users again. We are continuing to monitor this.
Posted 30 Aug at 09:00pm BST.

Created
The item fetch feature (powered by Product Scrapes) does not return results for some users.
Posted 25 Aug at 05:10pm BST.